flake/systems/etna/hardware-configuration.nix
uku 735fa9d2d6
fix(etna): switch back to kernel 6.1
it seems that there is a regression in the network driver in 6.6+,
so can't really use that right now, otherwise the whole pc
freezes when reconnecting to the internet
2024-05-06 12:02:21 +02:00

49 lines
1.6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Do not modify this file! It was generated by nixos-generate-config
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
{
config,
lib,
pkgs,
modulesPath,
...
}: {
imports = [
(modulesPath + "/installer/scan/not-detected.nix")
];
boot.initrd.availableKernelModules = ["xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod"];
boot.initrd.kernelModules = [];
boot.kernelModules = ["kvm-intel"];
boot.extraModulePackages = [];
fileSystems."/" = {
device = "/dev/disk/by-uuid/e136f8ad-b8d5-4706-ad24-725926fd50ec";
fsType = "ext4";
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/FBB1-A79D";
fsType = "vfat";
options = ["fmask=0022" "dmask=0022"];
};
fileSystems."/data" = {
device = "/dev/disk/by-uuid/a60648d1-0288-49a0-a5cb-7079ed5f9bf9";
fsType = "ext4";
};
swapDevices = [
{device = "/dev/disk/by-uuid/4982538e-5402-44c0-86c6-bf086c856615";}
];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's
# still possible to use this option, but it's recommended to use it in conjunction
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
networking.useDHCP = lib.mkDefault true;
# networking.interfaces.eno1.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}